Бухгалтерский учет. Налоги. Аудит

Форум – 1С:Бухгалтерия, ЗиК и др.

Обсуждаем:

При обновлении 1с бухии 7.7. обнулился справочник страховых взносов

10.10.2011, 15:12
При попытке заполнения выдает ошибку:
глСпрТарифСтраховыхВзносов.ПФР.Установить(Дата(Период,01,01), ВремТаблица.ПФР);
{Обработка.СтавкиСтраховыхВзносов.Форма.Модуль(325)}: Не выбран элемент!
10.10.2011, 17:50
Решение вопроса:
модуль обработки, заменить кусок кода:
Если глСпрТарифСтраховыхВзносов.НайтиПоРеквизиту("ВидТарифа",ВремТаблица.ВидТарифа,0) = 0 Тогда
глСпрТарифСтраховыхВзносов.Новый();
КонецЕсли;

на этот:

Если глСпрТарифСтраховыхВзносов.НайтиПоРеквизиту("ВидТарифа",ВремТаблица.ВидТарифа,0) = 0 Тогда
глСпрТарифСтраховыхВзносов.Новый();
глСпрТарифСтраховыхВзносов.ВидТарифа=ВремТаблица.ВидТарифа;
глСпрТарифСтраховыхВзносов.Записать();
КонецЕсли;
Random  
10.10.2011, 18:00
Глазки, респект круто!
Alex8888888888 (08e29)
11.11.2015, 08:39
Решение вопроса: 
модуль обработки, заменить кусок кода: 
Если глСпрТарифСтраховыхВзносов.НайтиПоРеквизиту("ВидТарифа",ВремТаблица.ВидТарифа,0) = 0 Тогда 
глСпрТарифСтраховыхВзносов.Новый(); 
КонецЕсли; 

на этот: 

Если глСпрТарифСтраховыхВзносов.НайтиПоРеквизиту("ВидТарифа",ВремТаблица.ВидТарифа,0) = 0 Тогда 
глСпрТарифСтраховыхВзносов.Новый(); 
глСпрТарифСтраховыхВзносов.ВидТарифа=ВремТаблица.ВидТарифа; 
глСпрТарифСтраховыхВзносов.Записать(); 
КонецЕсли;
Вопрос: как заменить этот кусок? в отладчике не редактируется а в конфигураторе не могу найти такие строчки? Скажите пожалуйстасмайлик
sWin (34949)
18.02.2016, 19:29
Как вариант, чтобы не забивать вручную, перегрузить справочник "тарифстраховыхвзносов" из работающего экземпляра базы с помощью обработины TranRef.ert с диска ИТС. Занимает меньше минуты
sWin (34949)
18.02.2016, 19:37
Alex8888888888, в пофигураторе оно в обработке"СтавкиСтраховыхВзносов", а, не в справочнике
При открытом конфигураторе, просто, кликнуть на эррор в табле крысой два раза, прого перекинет на нужную строчку в модуле автоматически...
Править смысла нет, особо, при обновлении этот фикс затрется(если о нем не вспомните))), проще перегрузить из"живого" справочника и забытьсмайлик
ЗЫ: такая пакость возникает, еще, при переносе данных обработками с диска ИТС, которые называются Import77 и Export77...Почему - то, они переносят, только один элемент справочника тарифов - последний(не смотрел, почему, ленивасмайлик)...Просто, при переносе надо быть осторожнее, отключить этот справочник в списке справочников
Автор:
Ваш Email:

Защита от спама:
Введите код, который вы видете ниже (защита от роботов-спамеров).
 **     **   *******   **     **   *******   **     ** 
 ***   ***  **     **  ***   ***  **     **   **   **  
 **** ****  **     **  **** ****  **           ** **   
 ** *** **   ********  ** *** **  ********      ***    
 **     **         **  **     **  **     **    ** **   
 **     **  **     **  **     **  **     **   **   **  
 **     **   *******   **     **   *******   **     ** 
Сообщение: