Бухгалтерский учет. Налоги. Аудит

Форум – 1С:Бухгалтерия, ЗиК и др.

Обсуждаем:
Все файлы из этой темы

Имя файла Размер файлов   Написал Дата  
error1.png 67.2 KB открыть | скачать Aiba 31.03.2017 Читать сообщение

Ошибка в настройке упр. учета

Aiba  4cfd  
31.03.2017, 14:37
Добрый день! Проблема в общем следующая... Купили базу у коллег (подходит по возможностям) Начали настраивать под себя, пытались создать учетную политику все заполняем, жмем ОК и тут выходит ошибка (фото)


Содержимое из конфигуратора:

Процедура ПередЗаписьюРегистраДатаЗапретаРедактированияПередЗаписью(Источник, Отказ, Замещение) Экспорт

Если ТипЗнч(Источник.Отбор.Регистратор.Значение) = Тип("ДокументСсылка.ЗаказПокупателя")
или ТипЗнч(Источник.Отбор.Регистратор.Значение) = Тип("ДокументСсылка.ЗаказПоставщику")
ИЛИ ТипЗнч(Источник.Отбор.Регистратор.Значение) = Тип("ДокументСсылка.ПеремещениеТоваров") тогда
ВОзврат;
КонецЕсли;

ПроверкаПериодаЗаписейРегистров(Источник, Отказ);
Если Отказ Тогда
#Если Клиент Тогда
Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
#КонецЕсли
КонецЕсли;

КонецПроцедуры // ПередЗаписьюРегистраДатаЗапретаРедактированияПередЗаписью()
Вложения:
открыть | скачать - error1.png (67.2 KB)
Aiba  4cfd  
31.03.2017, 15:42
Что посоветуете?
Автор:
Ваш Email:

Защита от спама:
Введите код, который вы видете ниже (защита от роботов-спамеров).
 **     **  **    **  ********   **     **   *******  
 ***   ***   **  **   **     **  ***   ***  **     ** 
 **** ****    ****    **     **  **** ****         ** 
 ** *** **     **     **     **  ** *** **   *******  
 **     **     **     **     **  **     **         ** 
 **     **     **     **     **  **     **  **     ** 
 **     **     **     ********   **     **   *******  
Сообщение: